Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 24, 2026 - 09:30 CET
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 24, 2026 - 09:30 CET
Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 24, 2026 - 09:28 CET
Scheduled
Between Tuesday 2026-02-24 09:00 UTC+1 and Tuesday 2026-02-24 10:00 UTC+1, a scheduled maintenance activity will be conducted on the Securosys HQ infrastructure.
What is the impact? During the maintenance window, Securosys perimeter infrastructure will undergo maintenance. As a result, some services may experience temporary downtime.
This maintenance is required to maintain the security, stability, and reliability of Securosys HQ services.
Posted Feb 24, 2026 - 09:24 CET
This scheduled maintenance affected: Developer Program (CloudsHSM Developer Program (DEV), Switzerland, CloudsHSM RESTful API Developer, CloudsHSM RESTful API Demo) and Securosys SA (CloudConsole (Purchasing Platform for CloudHSM)).