CLOUDHSM (ECO, PLA)- SCHEDULED MAINTENANCE

Scheduled for Sep 18, 09:00 - 16:00 CEST

Update

We will be undergoing scheduled maintenance during this time.
Posted Aug 06, 2025 - 15:30 CEST

Scheduled

We are announcing herewith scheduled maintenance activities on the CloudHSM infrastructure.

The maintenance activities are scheduled on the following day: Thursday, 18. September 2025, 09:00 - 16:00 CEST for the following HSM-Clusters: CloudHSM Economy (ECO) and Platinum (PLA), Global, Switzerland, Germany, US-East, US-West, Singapore

During the maintenance window, the planned firmware update to PrimusHSM release 3.2.6 of the CloudHSM Economy (ECO) and (PLA) will be made. CloudHSM HSMaaS users may consult the Primus HSM firmware release notes for a detailed feature and improvement list.

The changes are not expected to affect the availability of the service. Please contact us via the support portal support portal if you experience any issues with service access.
Posted Sep 18, 2025 - 09:00 CEST
This scheduled maintenance affects: Securosys CloudHSM (CloudHSM Economy (ECO), USA, CloudHSM Economy (ECO), Germany, CloudHSM Economy (ECO), Singapore, CloudHSM Economy (ECO), Switzerland, CloudHSM Economy (ECO), Global), Transaction Security Broker (TSB) / RestAPI (CloudsHSM RESTful API ECO), and Securosys365 (Double Key Encryption Service).